Home > Java Error > Java Error Unsupported Major.minor Version 51.0

Java Error Unsupported Major.minor Version 51.0

Could winds of up to 150 km/h impact the structural loads on a Boeing 777? Should I install the JDK, and setup my path variable to the JDK instead of JRE? So basically you must have compiled your code with a higher version and trying to run it using a lower version. Join them; it only takes a minute: Sign up Java Stacktrace error Unsupported major.minor version 51.0 [duplicate] up vote 11 down vote favorite 2 Possible Duplicate: unsupported major .minor version 51.0 Source

For more information, see the docs on Java Web Start and JNLP here. gablank, 4, 2012 #10 Offline annamalai4445 gablank can u please explain me the steps in detail i also hve the same probelm annamalai4445, 23, 2012 #11 Offline gablank Right click So the solution is to either: Upgrade your Java runtime or Recompile the class if you have the source, using your local Java compiler (if you have one). Get early access to new articles, plugins, discount codes and brief updates about what's new with Crunchify!

You need to install 32-bit or 64-bit JDK 1.7 or JRE 1.7 version depending upon whether you are running on 32-bit or 64-bit OS e.g. Upgrade JRE to get a version same or higher than the version you have used for compiling your project. Love SEO, SaaS, #webperf, WordPress, Java.

  1. Since 51.0 belongs to Java 7, it means class files are created by compiler shipped along with JDK 1.7.
  2. MMO-Champion MMO-Champion Keep ahead with the champions of WoW coverage.
  3. Java program to read File in Java - Windows UNIX ► September (25) ► August (37) ► July (3) Powered by Blogger.
  4. http://wiki.bukkit.org/Setting_up_a_server ItsHarry, 30, 2011 #8 Offline darker9999 asdfaf11 said: ↑ I changed the build level to 1.6 and at the java build path, libraries the JRE System library is jre6.
  5. I've noticed that the default JRE is changed for each project I work on when using this setup.
  6. c) Run your compiled classes in a JRE that is the same, or newer, version as the JDK used to compile the classes.
  7. share|improve this answer answered Jun 15 '12 at 23:02 templatetypedef 200k44500756 I can run it on this computer but not others.
  8. Privacy Policy Log in or Sign up Bukkit Forums Home Forums > Bukkit > Plugin Development > [Solved] Java problem?

Already have an account? Can an umlaut be written as a line in handwriting? Select Java Compiler option, as shown below, you will see that JDK 1.7 was selected by default 3. Thread Status: Not open for further replies.

Get latest update on and . which javac will tell you the location, for example, /usr/bin/javac. Why was the identity of the Half-Blood Prince important to the story? 2002 research: speed of light slowing down? How to iterate over HashSet in Java - loop or trav...

How to convert ArrayList to String in Java - Sprin... more hot questions lang-java about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science Other Finding the distance between two points in C++ Make an ASCII bat fly around an ASCII moon Why is JK Rowling considered 'bad at math'? Like so: javac -source 1.6 -target 1.6 -bootclasspath /usr/lib/jvm/java-6-openjdk-i386/jre/lib/rt.jar HelloWorld.java It looks like you can just download rt.jar from the Internet, and point to it.

I'm not exactly sure how I can remedy this and would appreciate some advice. Must I download it ? –user3120480 Dec 19 '13 at 19:43 1 @user3120480:- No you dont need to download eclipse if you dont have then you may try with apt-get share|improve this answer edited Jul 12 '14 at 20:29 Peter Mortensen 10.3k1369107 answered Jan 7 '14 at 6:43 user3168034 7111 add a comment| up vote 6 down vote I have faced Other Java debugging and troubleshooting articles How to remote debugging Java application in Eclipse 10 Java debugging tips in Eclipse IDE How to fix java.util.NoSuchElementException in Java How to fix java.sql.SQLException:

It's actually pretty easy to upgrade your JVM. 1) Download the latest Java 7 JRE. 2) Install the downloaded JRE. 3) Go to Add/Remove programs and remove the old JRE version this contact form posted 4 years ago Hi Jeff, Thanks for the prompt reply. A: If you compile an application using javac in Java 7, the resulting classfiles will have the 51.0 version number. SQL Server Memory allocation and max server memory setting Public huts to stay overnight around UK Recruiter wants me to take a loss upon hire When does bugfixing become overkill, if

I appreciate the details you guys go into when explaining. share|improve this answer answered Jun 26 '14 at 7:40 Sagar Varpe 1,29241636 add a comment| up vote 1 down vote First let's get some basics right... That worked for me. have a peek here Why did my electrician put metal plates wherever the stud is drilled through?

i.e. share|improve this answer edited Nov 7 '14 at 14:31 Peter Mortensen 10.3k1369107 answered Aug 4 '14 at 10:21 siddmuk2005 316 add a comment| up vote 1 down vote How do I Should I install the JDK, and setup my path variable to the JDK instead of JRE?

Usually because the version of Java that generated your class file (i.e.

How to fix Chrome, Firefox Blurry, Over bright, fa... ► July ( 18 ) ► June ( 16 ) ► May ( 5 ) ► April ( 4 ) ► March Is foreign stock considered more risky than local stock and why? share|improve this answer answered Mar 26 '15 at 9:42 Vihung 4,335103357 add a comment| up vote 1 down vote Oh Mac OS X I was able to solve this problem by Top 10 Servlet JSP Interview Questions for Java J2...

posted 4 years ago Thanks for the clarification Rob. It turned out that under Eclipse you can specify the environment that Ant should be running with and this was set as a JRE instead of a JDK. I used cloudsim3 library in my project and i want to run example 1 of it. http://canondrivebh.com/java-error/java-error-exception-in-thread-main-java-lang-noclassdeffounderror.html When we used "/etc/init.d/tomcat7 [stop/start]" to restart Tomcat 7, the problem was solved. $ ps -ef | grep java tomcat7 31886 1 80 20:24 ? 00:00:10 /usr/local/java/jdk1.7.0_15/bin/java $ /usr/local/java/jdk1.7.0_15/bin/java -version java

Since they internally use javac compiler to compile the file, you need to customize corresponding task e.g. That's basically the same as using the third option Jeff provided, only it's the IDE that does it for you. On Mac OS X you can get this problem: http://stackoverflow.com/questions/12757558/installed-java-7-on-mac-os-x-but-terminal-is-still-using-version-6 Hope this helps - let me know how it goes! 🎱 … On 4 Oct 2015 06:31, "Joe Saavedra" ***@***.***> wrote: java jvm incompatibility unsupported-class-version share|improve this question edited Oct 11 at 18:49 Victor Stafusa 5,31763054 asked Apr 30 '12 at 11:28 ERJAN 6,33451635 did you install jdk as well

more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed How to unlink (remove) the special hardlink "." created for a folder?